summaryrefslogtreecommitdiff
path: root/arch/init/PKGBUILD
diff options
context:
space:
mode:
authorUrbain Vaes <urbain@vaes.uk>2019-04-03 17:05:19 +0200
committerUrbain Vaes <urbain@vaes.uk>2019-04-08 12:46:41 +0200
commit12b6a06de8b82881e6b5e9694a6cd7bec1b119ec (patch)
tree5f1eb5b25799092a675f6e351642b186a1ba6077 /arch/init/PKGBUILD
parent32897a60236cc810b7a8c154c7d7deaba1b01323 (diff)
[arch] Add basic install package
Diffstat (limited to 'arch/init/PKGBUILD')
-rw-r--r--arch/init/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/arch/init/PKGBUILD b/arch/init/PKGBUILD
new file mode 100644
index 0000000..404589e
--- /dev/null
+++ b/arch/init/PKGBUILD
@@ -0,0 +1,24 @@
+# makepkg -sf
+# sudo pacman -Uv --overwrite ...
+
+pkgname=my-init
+pkgver=0
+pkgrel=1
+arch=(any)
+
+source=('vconsole.conf'
+ 'sudoers'
+ 'locale.gen'
+ 'locale.conf'
+ 'override.conf')
+
+md5sums=(SKIP SKIP SKIP SKIP SKIP)
+install=my-init.install
+
+package() {
+ install -Dm 0644 override.conf "$pkgdir/etc/systemd/system/getty@tty1.service.d/override.conf"
+ install -Dm 0644 vconsole.conf "$pkgdir/etc/vconsole.conf"
+ install -Dm 0644 locale.gen "$pkgdir/etc/locale.gen"
+ install -Dm 0644 locale.conf "$pkgdir/etc/locale.conf"
+ install -Dm 0440 sudoers "$pkgdir/etc/sudoers"
+}